at91: introduce vendor_model scheme and drop board names
[openwrt/staging/wigyori.git] / package / boot / at91bootstrap / Makefile
index eaec26b4a113780ca31af568532e4d4d13a6c964..08fe2a49b05b48e4a89b3a206cc8067594114d3c 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=at91bootstrap
 PKG_VERSION:=v3.9.3
-PKG_RELEASE:=
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/linux4sam/at91bootstrap.git
@@ -30,91 +30,91 @@ endef
 define AT91Bootstrap/at91sam9x5eknf_uboot
   NAME:=AT91Bootstrap for AT91SAM9X5-EK board (NandFlash)
   BUILD_SUBTARGET:=sam9x
-  BUILD_DEVICES:=at91sam9x25ek at91sam9x35ek
+  BUILD_DEVICES:=atmel_at91sam9x25ek atmel_at91sam9x35ek
 endef
 
 define AT91Bootstrap/at91sam9x5eksd_uboot
   NAME:=AT91Bootstrap for AT91SAM9X5-EK board (SDcard)
   BUILD_SUBTARGET:=sam9x
-  BUILD_DEVICES:=at91sam9x25ek at91sam9x35ek
+  BUILD_DEVICES:=atmel_at91sam9x25ek atmel_at91sam9x35ek
 endef
 
 define AT91Bootstrap/sama5d2_xplaineddf_uboot
   TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (SPI Flash)
   BUILD_SUBTARGET:=sama5
-  BUILD_DEVICES:=at91-sama5d2_xplained
+  BUILD_DEVICES:=microchip_sama5d2-xplained
 endef
 
 define AT91Bootstrap/sama5d2_xplaineddf_qspi_uboot
   TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (QSPI Flash)
   BUILD_SUBTARGET:=sama5
-  BUILD_DEVICES:=at91-sama5d2_xplained
+  BUILD_DEVICES:=microchip_sama5d2-xplained
 endef
 
 define AT91Bootstrap/sama5d2_xplainedsd_uboot
   TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (SDcard/EMMC)
   BUILD_SUBTARGET:=sama5
-  BUILD_DEVICES:=at91-sama5d2_xplained
+  BUILD_DEVICES:=microchip_sama5d2-xplained
 endef
 
 define AT91Bootstrap/sama5d3_xplainednf_uboot
   TITLE:=AT91Bootstrap for SAMA5D3 Xplained board (Nand Flash)
   BUILD_SUBTARGET:=sama5
-  BUILD_DEVICES:=at91-sama5d3_xplained
+  BUILD_DEVICES:=microchip_sama5d3-xplained
 endef
 
 define AT91Bootstrap/sama5d3_xplainedsd_uboot
   TITLE:=AT91Bootstrap for SAMA5D3 Xplained board (SDcard)
   BUILD_SUBTARGET:=sama5
-  BUILD_DEVICES:=at91-sama5d3_xplained
+  BUILD_DEVICES:=microchip_sama5d3-xplained
 endef
 
 define AT91Bootstrap/sama5d4_xplainednf_uboot_secure
   TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (Nand Flash)
   BUILD_SUBTARGET:=sama5
-  BUILD_DEVICES:=at91-sama5d4_xplained
+  BUILD_DEVICES:=microchip_sama5d4-xplained
 endef
 
 define AT91Bootstrap/sama5d4_xplaineddf_uboot_secure
   TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (SPI Flash)
   BUILD_SUBTARGET:=sama5
-  BUILD_DEVICES:=at91-sama5d4_xplained
+  BUILD_DEVICES:=microchip_sama5d4-xplained
 endef
 
 define AT91Bootstrap/sama5d4_xplainedsd_uboot_secure
   TITLE:=AT91Bootstrap for SAMA5D4 Xplained board (SDcard)
   BUILD_SUBTARGET:=sama5
-  BUILD_DEVICES:=at91-sama5d4_xplained
+  BUILD_DEVICES:=microchip_sama5d4-xplained
 endef
 
 define AT91Bootstrap/sama5d27_som1_eksd_uboot
   TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (SDcard0)
   BUILD_SUBTARGET:=sama5
-  BUILD_DEVICES:=at91-sama5d27_som1_ek
+  BUILD_DEVICES:=microchip_sama5d27-som1-ek
 endef
 
 define AT91Bootstrap/sama5d27_som1_eksd1_uboot
   TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (SDcard1)
   BUILD_SUBTARGET:=sama5
-  BUILD_DEVICES:=at91-sama5d27_som1_ek
+  BUILD_DEVICES:=microchip_sama5d27-som1-ek
 endef
 
 define AT91Bootstrap/sama5d27_som1_ekqspi_uboot
   TITLE:=AT91Bootstrap for SAMA5D27 SOM1 Ek (QSPI Flash)
   BUILD_SUBTARGET:=sama5
-  BUILD_DEVICES:=at91-sama5d27_som1_ek
+  BUILD_DEVICES:=microchip_sama5d27-som1-ek
 endef
 
 define AT91Bootstrap/sama5d2_ptc_eknf_uboot
   TITLE:=AT91Bootstrap for SAMA5D2 PTC EK (Nand Flash)
   BUILD_SUBTARGET:=sama5
-  BUILD_DEVICES:=at91-sama5d2_ptc_ek
+  BUILD_DEVICES:=microchip_sama5d2-ptc-ek
 endef
 
 define AT91Bootstrap/sama5d2_ptc_eksd_uboot
   TITLE:=AT91Bootstrap for SAMA5D2 PTC EK (SDCard)
   BUILD_SUBTARGET:=sama5
-  BUILD_DEVICES:=at91-sama5d2_ptc_ek
+  BUILD_DEVICES:=microchip_sama5d2-ptc-ek
 endef
 
 AT91BOOTSTRAP_TARGETS := \