at91: add support for sama5d2 icp board
[openwrt/staging/wigyori.git] / package / boot / at91bootstrap / Makefile
index f66472fa9c298c5e1167c2d92e5bfff920204b05..56e14c57703cb961facdaf4a47a585d7abc20794 100644 (file)
@@ -40,6 +40,18 @@ define AT91Bootstrap/at91sam9x5eksd_uboot
   BUILD_DEVICES:=atmel_at91sam9x25ek atmel_at91sam9x35ek
 endef
 
+define AT91Bootstrap/sama5d2_icpdf_qspi_uboot
+  TITLE:=AT91Bootstrap for SAMA5D2 ICP board (QSPI Flash)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=microchip_sama5d2-icp
+endef
+
+define AT91Bootstrap/sama5d2_icpsd_uboot
+  TITLE:=AT91Bootstrap for SAMA5D2 ICP board (SDcard)
+  BUILD_SUBTARGET:=sama5
+  BUILD_DEVICES:=microchip_sama5d2-icp
+endef
+
 define AT91Bootstrap/sama5d2_xplaineddf_uboot
   TITLE:=AT91Bootstrap for SAMA5D2 Xplained board (SPI Flash)
   BUILD_SUBTARGET:=sama5
@@ -121,6 +133,8 @@ endef
 AT91BOOTSTRAP_TARGETS := \
        at91sam9x5eknf_uboot \
        at91sam9x5eksd_uboot \
+       sama5d2_icpdf_qspi_uboot \
+       sama5d2_icpsd_uboot \
        sama5d2_xplaineddf_uboot \
        sama5d2_xplaineddf_qspi_uboot \
        sama5d2_xplainedsd_uboot \