gdb: bump to 8.3.1
[openwrt/staging/wigyori.git] / package / devel / gdb / patches / 110-shared_libgcc.patch
index c8ddfde5cca908f208fc9078413f8293304bdd71..f07ac8ca24ba37dc634a01e5761d1ff61eb713d7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1277,13 +1277,13 @@ if test -z "$LD"; then
+@@ -1283,13 +1283,13 @@ if test -z "$LD"; then
    fi
  fi
  
    AC_LANG_PUSH(C++)
    AC_LINK_IFELSE([AC_LANG_SOURCE([
  #if (__GNUC__ < 4) || (__GNUC__ == 4 && __GNUC_MINOR__ < 5)
-@@ -1609,7 +1609,7 @@ AC_ARG_WITH(stage1-ldflags,
-  # if supported.  But if the user explicitly specified the libraries to use,
+@@ -1629,7 +1629,7 @@ AC_ARG_WITH(stage1-ldflags,
   # trust that they are doing what they want.
-  if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
+  if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
+      -a "$have_static_libs" = yes; then
 -   stage1_ldflags="-static-libstdc++ -static-libgcc"
 +   stage1_ldflags="-static-libstdc++"
   fi])
  AC_SUBST(stage1_ldflags)
  
-@@ -1638,7 +1638,7 @@ AC_ARG_WITH(boot-ldflags,
+@@ -1658,7 +1658,7 @@ AC_ARG_WITH(boot-ldflags,
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then
@@ -37,7 +37,7 @@
  
 --- a/configure
 +++ b/configure
-@@ -5043,14 +5043,14 @@ if test -z "$LD"; then
+@@ -5053,14 +5053,14 @@ if test -z "$LD"; then
    fi
  fi
  
    ac_ext=cpp
  ac_cpp='$CXXCPP $CPPFLAGS'
  ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
-@@ -5833,7 +5833,7 @@ else
-  # if supported.  But if the user explicitly specified the libraries to use,
+@@ -5861,7 +5861,7 @@ else
   # trust that they are doing what they want.
-  if test "$stage1_libs" = "" -a "$have_static_libs" = yes; then
+  if test "$with_static_standard_libraries" = yes -a "$stage1_libs" = "" \
+      -a "$have_static_libs" = yes; then
 -   stage1_ldflags="-static-libstdc++ -static-libgcc"
 +   stage1_ldflags="-static-libstdc++"
   fi
  fi
  
-@@ -5869,7 +5869,7 @@ else
+@@ -5897,7 +5897,7 @@ else
   # statically.  But if the user explicitly specified the libraries to
   # use, trust that they are doing what they want.
   if test "$poststage1_libs" = ""; then