build: fix including modules.mk for targets pulled in from feeds
[openwrt/staging/wigyori.git] / package / kernel / linux / Makefile
index 9fa68d78f722f414de60a01467615fa2220a20b1..ad68bde9b3137b27554742ac49dae5c693b9f923 100644 (file)
@@ -12,7 +12,7 @@ PKG_NAME:=kernel
 PKG_FLAGS:=hold
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/packages
-SCAN_DEPS=modules/*.mk $(TOPDIR)/target/linux/*/modules.mk $(TOPDIR)/include/netfilter.mk
+SCAN_DEPS=modules/*.mk $(TOPDIR)/target/linux/*/modules.mk $(TOPDIR)/target/linux/*/*/modules.mk $(TOPDIR)/include/netfilter.mk
 
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=
@@ -64,3 +64,4 @@ $(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
 
 include $(sort $(wildcard ./modules/*.mk))
 -include $(TOPDIR)/target/linux/*/modules.mk
+-include $(TOPDIR)/target/linux/*/*/modules.mk