kernel: update kmod-* packaging and dependencies for linux 4.9
[openwrt/staging/wigyori.git] / package / kernel / linux / modules / netsupport.mk
index 3d5e74327aaf9da90fc94ed2baaee66cd8caa42a..bed08286345c8e16c078f1b59672bb95246e2e43 100644 (file)
@@ -533,7 +533,7 @@ $(eval $(call KernelPackage,gre))
 define KernelPackage/gre6
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=GRE support over IPV6
-  DEPENDS:=@IPV6 +kmod-iptunnel +kmod-ip6-tunnel
+  DEPENDS:=@IPV6 +kmod-iptunnel +kmod-ip6-tunnel +kmod-gre
   KCONFIG:=CONFIG_IPV6_GRE
   FILES:=$(LINUX_DIR)/net/ipv6/ip6_gre.ko
   AUTOLOAD:=$(call AutoLoad,39,ip6_gre)