package/kernel: adjust kmod-crc16 dependencies, it does not exist on 2.4
[openwrt/staging/wigyori.git] / package / kernel / modules / 001-depends.mk
index 61d892198ec6d0a27c84f277f851c74446a142b6..5bba0870ee78305ccef7a6bd712331c19383b2e5 100644 (file)
@@ -8,11 +8,11 @@
 # XXX: xburst has CONFIG_CRC16=y because of CONFIG_UBIFS_FS=y
 
 define SetDepends/crc16
-  DEPENDS:= @!TARGET_xburst
+  DEPENDS:= @!(LINUX_2_4||TARGET_xburst)
 endef
 
 define AddDepends/crc16
-  DEPENDS+= +!TARGET_xburst:kmod-crc16 $(1)
+  DEPENDS+= +!(LINUX_2_4||TARGET_xburst):kmod-crc16 $(1)
 endef