packages: clean up the package folder
[openwrt/staging/wigyori.git] / package / kernel / switch / src / Makefile
diff --git a/package/kernel/switch/src/Makefile b/package/kernel/switch/src/Makefile
new file mode 100644 (file)
index 0000000..b6934cc
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Makefile for switch driver
+#
+# Copyright (C) 2005 Felix Fietkau <nbd@openwrt.org>
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version
+# 2 of the License, or (at your option) any later version.
+#
+
+obj-m  := switch-core.o switch-adm.o switch-robo.o
+
+ifeq ($(MAKING_MODULES),1)
+export-objs := switch-core.o
+
+-include $(TOPDIR)/Rules.make
+endif