spidev_test: copy the source code into the package folder
[openwrt/staging/wigyori.git] / package / utils / spidev_test / Makefile
index 631ef0dd2407628ceb479c94961a1a50d8856019..e92bf63ccb62937cebef5850f5dadceeb692d88c 100644 (file)
@@ -28,20 +28,12 @@ define Package/spidev-test/description
 endef
 
 define Build/Prepare
+       $(CP) src/spidev_test.c $(PKG_BUILD_DIR)/
 endef
 
-# requires 214-spidev_h_portability.patch
-# or linux/ioctl.h include on musl
 define Build/Compile
-
-ifneq ($(CONFIG_LINUX_3_18)$(CONFIG_LINUX_4_1)$(CONFIG_LINUX_4_4),y)
-       $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/spidev_test \
-               $(LINUX_DIR)/tools/spi/spidev_test.c
-else
        $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/spidev_test \
-               $(LINUX_DIR)/Documentation/spi/spidev_test.c
-endif
-
+               $(PKG_BUILD_DIR)/spidev_test.c
 endef
 
 define Package/spidev-test/install