util-linux: update to 2.39.2
[openwrt/staging/wigyori.git] / package / utils / util-linux / patches / 001-meson-properly-handle-gettext-non-existence.patch
diff --git a/package/utils/util-linux/patches/001-meson-properly-handle-gettext-non-existence.patch b/package/utils/util-linux/patches/001-meson-properly-handle-gettext-non-existence.patch
new file mode 100644 (file)
index 0000000..f3d49d8
--- /dev/null
@@ -0,0 +1,28 @@
+From b8bed37a1493b913bf5bda938487ae0c06c11ce7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Thomas=20Wei=C3=9Fschuh?= <thomas@t-8ch.de>
+Date: Sat, 5 Aug 2023 08:57:28 +0200
+Subject: [PATCH] meson: properly handle gettext non-existence
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Commit e91a49c9747f ("meson: don't build po if no gettext")
+tried to add the possibility to build util-linux without gettext.
+
+Unfortunately by default the call to find_program() would abort the
+build if the program is not found.
+Avoid aborting the build.
+
+Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de>
+---
+ po/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/po/meson.build
++++ b/po/meson.build
+@@ -1,4 +1,4 @@
+-if not find_program('gettext').found()
++if not find_program('gettext', required : false).found()
+   subdir_done()
+ endif