util-linux: use meson to build
[openwrt/staging/wigyori.git] / package / utils / util-linux / patches / 050-meson-fix-environ-search.patch
diff --git a/package/utils/util-linux/patches/050-meson-fix-environ-search.patch b/package/utils/util-linux/patches/050-meson-fix-environ-search.patch
new file mode 100644 (file)
index 0000000..2cd02e5
--- /dev/null
@@ -0,0 +1,23 @@
+From 1e9e2b9fe365cc4a0025d44dc0a9c54bfffe9058 Mon Sep 17 00:00:00 2001
+From: Rosen Penev <rosenp@gmail.com>
+Date: Fri, 29 Apr 2022 18:16:17 -0700
+Subject: [PATCH 4/7] meson: fix environ search
+
+musl has it defined in unistd.h and hidden behind _GNU_SOURCE.
+
+Signed-off-by: Rosen Penev <rosenp@gmail.com>
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/meson.build
++++ b/meson.build
+@@ -382,7 +382,7 @@ conf.set10('HAVE_DECL_CPU_ALLOC', have)
+ have_cpu_set_t = cc.sizeof('cpu_set_t', prefix : '#define _GNU_SOURCE\n#include <sched.h>') > 0
+ conf.set('HAVE_CPU_SET_T', have_cpu_set_t ? 1 : false)
+-have = cc.has_header_symbol('stdlib.h', 'environ')
++have = cc.has_header_symbol('unistd.h', 'environ', prefix : '#define _GNU_SOURCE')
+ conf.set10('HAVE_ENVIRON_DECL', have)
+ have = cc.has_header_symbol('signal.h', 'sighandler_t')