brcm47xx: add a "legacy" subtarget that is usable for low-end 802.11g devices like...
[openwrt/staging/wigyori.git] / target / linux / brcm47xx / legacy / profiles / 101-Broadcom-wl.mk
diff --git a/target/linux/brcm47xx/legacy/profiles/101-Broadcom-wl.mk b/target/linux/brcm47xx/legacy/profiles/101-Broadcom-wl.mk
new file mode 100644 (file)
index 0000000..6a4c5b0
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-wl
+  NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (wl, proprietary)
+  PACKAGES:=-wpad-mini kmod-brcm-wl-mini wlc nas
+endef
+
+define Profile/Broadcom-wl/Description
+       Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+       SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
+       wireless "wl" driver and b44, tg3 or bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-wl))
+