ipq806x: add support for Askey RT4230W REV6
[openwrt/staging/wigyori.git] / target / linux / ipq806x / image / Makefile
index 6c091be33558c4ffeaf1acd7da89fa7f341cbdab..e53fba1e1d4396fbeba62143104b0b0ef4efac33 100644 (file)
@@ -90,6 +90,19 @@ define Device/ZyXELImage
        IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-to $$$$(BLOCKSIZE) | sysupgrade-tar rootfs=$$$$@ | append-metadata
 endef
 
+define Device/askey_rt4230w-rev6
+       $(call Device/LegacyImage)
+       DEVICE_VENDOR := Askey
+       DEVICE_MODEL := RT4230W
+       DEVICE_VARIANT := REV6
+       SOC := qcom-ipq8065
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       DEVICE_PACKAGES := ath10k-firmware-qca9984-ct
+       KERNEL_IN_UBI := 1
+endef
+TARGET_DEVICES += askey_rt4230w-rev6
+
 define Device/asrock_g10
        $(call Device/FitImage)
        $(call Device/UbiFit)