layerscape: update patches-4.14 to LSDK 19.03
[openwrt/staging/wigyori.git] / target / linux / layerscape / patches-4.14 / 201-config-support-layerscape.patch
index 7ab88b5e9946148dc5bbd97d9151579a5475ac0b..7974a5051ace86e56721e53bde3ed3ff01029ec7 100644 (file)
@@ -1,6 +1,6 @@
-From 0bafdb711c1a61fbe5bb5b4d4bb5e32425d95a72 Mon Sep 17 00:00:00 2001
-From: Biwen Li <biwen.li@nxp.com>
-Date: Fri, 16 Nov 2018 15:36:03 +0800
+From 2a1351617985ef47581de825ae1bbf1d42bf3200 Mon Sep 17 00:00:00 2001
+From: Yangbo Lu <yangbo.lu@nxp.com>
+Date: Mon, 6 May 2019 17:29:32 +0800
 Subject: [PATCH] config: support layerscape
 MIME-Version: 1.0
 Content-Type: text/plain; charset=UTF-8
@@ -10,45 +10,65 @@ This is an integrated patch of config for layerscape
 
 Signed-off-by: Alison Wang <alison.wang@nxp.com>
 Signed-off-by: Bharat Bhushan <Bharat.Bhushan@nxp.com>
+Signed-off-by: Biwen Li <biwen.li@nxp.com>
+Signed-off-by: Bjorn Helgaas <bhelgaas@google.com>
 Signed-off-by: Bogdan Purcareata <bogdan.purcareata@nxp.com>
 Signed-off-by: Calvin Johnson <calvin.johnson@nxp.com>
 Signed-off-by: Camelia Groza <camelia.groza@nxp.com>
 Signed-off-by: Chenhui Zhao <chenhui.zhao@nxp.com>
+Signed-off-by: Florin Chiculita <florinlaurentiu.chiculita@nxp.com>
 Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
 Signed-off-by: Horia Geantă <horia.geanta@nxp.com>
+Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
 Signed-off-by: Ioana Ciornei <ioana.ciornei@nxp.com>
 Signed-off-by: Ioana Radulescu <ruxandra.radulescu@nxp.com>
 Signed-off-by: Li Yang <leoyang.li@nxp.com>
+Signed-off-by: Lorenzo Pieralisi <lorenzo.pieralisi@arm.com>
 Signed-off-by: Madalin Bucur <madalin.bucur@nxp.com>
+Signed-off-by: Pankaj Bansal <pankaj.bansal@nxp.com>
 Signed-off-by: Pankit Garg <pankit.garg@nxp.com>
 Signed-off-by: Prabhakar Kushwaha <prabhakar.kushwaha@nxp.com>
 Signed-off-by: Ran Wang <ran.wang_1@nxp.com>
 Signed-off-by: Razvan Stefanescu <razvan.stefanescu@nxp.com>
 Signed-off-by: Shengzhou Liu <Shengzhou.Liu@nxp.com>
+Signed-off-by: Subrahmanya Lingappa <l.subrahmanya@mobiveil.co.in>
+Signed-off-by: Xiaowei Bao <xiaowei.bao@nxp.com>
 Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
+Signed-off-by: Yogesh Gaur <yogeshnarayan.gaur@nxp.com>
 Signed-off-by: Zhang Ying-22455 <ying.zhang22455@nxp.com>
-Signed-off-by: Zhao Qiang  <qiang.zhao@nxp.com>
-Signed-off-by: Biwen Li <biwen.li@nxp.com>
+Signed-off-by: Zhao Qiang <qiang.zhao@nxp.com>
 ---
+ drivers/Makefile                        |  2 ++
  drivers/irqchip/Makefile                |  1 +
- drivers/net/ethernet/freescale/Kconfig  | 14 ++++----
+ drivers/net/ethernet/freescale/Kconfig  | 14 +++++----
  drivers/net/ethernet/freescale/Makefile |  3 ++
- drivers/ptp/Kconfig                     | 29 +++++++++++++++++
+ drivers/ptp/Kconfig                     | 16 +++++-----
  drivers/soc/Kconfig                     |  1 +
- drivers/soc/fsl/Kconfig                 | 11 +++++++
- drivers/soc/fsl/Kconfig.arm             | 16 +++++++++
- drivers/soc/fsl/Makefile                |  ++
+ drivers/soc/fsl/Kconfig                 | 22 +++++++++++++
+ drivers/soc/fsl/Kconfig.arm             | 16 ++++++++++
+ drivers/soc/fsl/Makefile                |  5 +++
  drivers/soc/fsl/layerscape/Kconfig      | 10 ++++++
  drivers/soc/fsl/layerscape/Makefile     |  1 +
  drivers/staging/Kconfig                 |  4 +++
  drivers/staging/Makefile                |  2 ++
- drivers/staging/fsl-dpaa2/Kconfig       | 43 ++++++++++++++++++++++++-
+ drivers/staging/fsl-dpaa2/Kconfig       | 56 ++++++++++++++++++++++++++++++++-
  drivers/staging/fsl-dpaa2/Makefile      |  4 +++
- 14 files changed, 135 insertions(+), 7 deletions(-)
+ 15 files changed, 142 insertions(+), 15 deletions(-)
  create mode 100644 drivers/soc/fsl/Kconfig.arm
  create mode 100644 drivers/soc/fsl/layerscape/Kconfig
  create mode 100644 drivers/soc/fsl/layerscape/Makefile
 
+--- a/drivers/Makefile
++++ b/drivers/Makefile
+@@ -20,6 +20,8 @@ obj-$(CONFIG_PCI)            += pci/
+ obj-$(CONFIG_PCI_ENDPOINT)    += pci/endpoint/
+ # PCI dwc controller drivers
+ obj-y                         += pci/dwc/
++# PCI mobiveil controller drivers
++obj-y                         += pci/mobiveil/
+ obj-$(CONFIG_PARISC)          += parisc/
+ obj-$(CONFIG_RAPIDIO)         += rapidio/
 --- a/drivers/irqchip/Makefile
 +++ b/drivers/irqchip/Makefile
 @@ -80,3 +80,4 @@ obj-$(CONFIG_ARCH_ASPEED)            += irq-aspeed
@@ -106,42 +126,34 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  obj-$(CONFIG_FSL_DPAA_ETH) += dpaa/
 --- a/drivers/ptp/Kconfig
 +++ b/drivers/ptp/Kconfig
-@@ -55,6 +55,35 @@ config PTP_1588_CLOCK_GIANFAR
+@@ -41,19 +41,19 @@ config PTP_1588_CLOCK_DTE
          To compile this driver as a module, choose M here: the module
-         will be called gianfar_ptp.
+         will be called ptp_dte.
+-config PTP_1588_CLOCK_GIANFAR
+-      tristate "Freescale eTSEC as PTP clock"
+-      depends on GIANFAR
++config PTP_1588_CLOCK_QORIQ
++      tristate "Freescale QorIQ 1588 timer as PTP clock"
++      depends on GIANFAR || FSL_DPAA_ETH || FSL_SDK_DPAA_ETH
+       depends on PTP_1588_CLOCK
+       default y
+       help
+-        This driver adds support for using the eTSEC as a PTP
+-        clock. This clock is only useful if your PTP programs are
+-        getting hardware time stamps on the PTP Ethernet packets
+-        using the SO_TIMESTAMPING API.
++        This driver adds support for using the Freescale QorIQ 1588
++        timer as a PTP clock. This clock is only useful if your PTP
++        programs are getting hardware time stamps on the PTP Ethernet
++        packets using the SO_TIMESTAMPING API.
+         To compile this driver as a module, choose M here: the module
+-        will be called gianfar_ptp.
++        will be called ptp_qoriq.
  
-+config PTP_1588_CLOCK_DPAA
-+      tristate "Freescale DPAA as PTP clock"
-+      depends on FSL_SDK_DPAA_ETH
-+      select PTP_1588_CLOCK
-+        select FSL_DPAA_TS
-+        default n
-+      help
-+        This driver adds support for using the DPAA 1588 timer module
-+        as a PTP clock. This clock is only useful if your PTP programs are
-+        getting hardware time stamps on the PTP Ethernet packets
-+        using the SO_TIMESTAMPING API.
-+
-+        To compile this driver as a module, choose M here: the module
-+        will be called dpaa_ptp.
-+
-+config PTP_1588_CLOCK_DPAA2
-+      tristate "Freescale DPAA2 as PTP clock"
-+      depends on FSL_DPAA2_ETH
-+      select PTP_1588_CLOCK
-+      default y
-+      help
-+        This driver adds support for using the DPAA2 1588 timer module
-+        as a PTP clock. This clock is only useful if your PTP programs are
-+        getting hardware time stamps on the PTP Ethernet packets
-+        using the SO_TIMESTAMPING API.
-+
-+        To compile this driver as a module, choose M here: the module
-+        will be called dpaa2-rtc.
-+
  config PTP_1588_CLOCK_IXP46X
        tristate "Intel IXP46x as PTP clock"
-       depends on IXP4XX_ETH
 --- a/drivers/soc/Kconfig
 +++ b/drivers/soc/Kconfig
 @@ -5,6 +5,7 @@ source "drivers/soc/amlogic/Kconfig"
@@ -154,11 +166,22 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  source "drivers/soc/qcom/Kconfig"
 --- a/drivers/soc/fsl/Kconfig
 +++ b/drivers/soc/fsl/Kconfig
-@@ -16,3 +16,14 @@ config FSL_GUTS
+@@ -16,3 +16,25 @@ config FSL_GUTS
          Initially only reading SVR and registering soc device are supported.
          Other guts accesses, such as reading RCW, should eventually be moved
          into this driver as well.
 +
++config FSL_QIXIS
++      tristate "QIXIS system controller driver"
++      depends on OF
++      select REGMAP_I2C
++      select REGMAP_MMIO
++      select MFD_CORE
++      default n
++      help
++        Say y here to enable QIXIS system controller api. The qixis driver
++        provides FPGA functions to control system.
++
 +config FSL_SLEEP_FSM
 +      bool
 +      help
@@ -190,11 +213,14 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
 +endif
 --- a/drivers/soc/fsl/Makefile
 +++ b/drivers/soc/fsl/Makefile
-@@ -6,3 +6,6 @@ obj-$(CONFIG_FSL_DPAA)                 +
+@@ -5,4 +5,9 @@
+ obj-$(CONFIG_FSL_DPAA)                 += qbman/
  obj-$(CONFIG_QUICC_ENGINE)            += qe/
  obj-$(CONFIG_CPM)                     += qe/
++obj-$(CONFIG_FSL_QIXIS)               += qixis_ctrl.o
  obj-$(CONFIG_FSL_GUTS)                        += guts.o
 +obj-$(CONFIG_FSL_LS2_CONSOLE)         += ls2-console/
++obj-$(CONFIG_SUSPEND)                 += rcpm.o
 +obj-$(CONFIG_LS_SOC_DRIVERS)          += layerscape/
 +obj-$(CONFIG_FSL_SLEEP_FSM)   += sleep_fsm.o
 --- /dev/null
@@ -244,7 +270,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
        ---help---
          Build drivers for Freescale DataPath Acceleration
          Architecture (DPAA2) family of SoCs.
-@@ -16,3 +16,44 @@ config FSL_DPAA2_ETH
+@@ -16,3 +16,57 @@ config FSL_DPAA2_ETH
        ---help---
          Ethernet driver for Freescale DPAA2 SoCs, using the
          Freescale MC bus driver
@@ -277,6 +303,19 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
 +          (PFC) in the driver.
 +
 +          If unsure, say N.
++
++config FSL_DPAA2_PTP_CLOCK
++      tristate "Freescale DPAA2 as PTP clock"
++      select PTP_1588_CLOCK
++      default y
++      help
++        This driver adds support for using the DPAA2 1588 timer module
++        as a PTP clock. This clock is only useful if your PTP programs are
++        getting hardware time stamps on the PTP Ethernet packets
++        using the SO_TIMESTAMPING API.
++
++        To compile this driver as a module, choose M here: the module
++        will be called dpaa2-rtc.
 +endif
 +
 +source "drivers/staging/fsl-dpaa2/mac/Kconfig"
@@ -297,5 +336,5 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  obj-$(CONFIG_FSL_DPAA2_ETH)   += ethernet/
 +obj-$(CONFIG_FSL_DPAA2_MAC)   += mac/
 +obj-$(CONFIG_FSL_DPAA2_EVB)   += evb/
-+obj-$(CONFIG_PTP_1588_CLOCK_DPAA2) += rtc/
++obj-$(CONFIG_FSL_DPAA2_PTP_CLOCK) += rtc/
 +obj-$(CONFIG_FSL_DPAA2_ETHSW) += ethsw/