layerscape: add patches-5.4
[openwrt/staging/wigyori.git] / target / linux / layerscape / patches-5.4 / 302-dts-0115-LF-789-2-arm64-dts-add-overlay-support-for-ls1028a-q.patch
diff --git a/target/linux/layerscape/patches-5.4/302-dts-0115-LF-789-2-arm64-dts-add-overlay-support-for-ls1028a-q.patch b/target/linux/layerscape/patches-5.4/302-dts-0115-LF-789-2-arm64-dts-add-overlay-support-for-ls1028a-q.patch
new file mode 100644 (file)
index 0000000..440e583
--- /dev/null
@@ -0,0 +1,36 @@
+From 911d3d1ea88ff6d56258d6173be7fc25290948a7 Mon Sep 17 00:00:00 2001
+From: Dong Aisheng <aisheng.dong@nxp.com>
+Date: Fri, 10 Jan 2020 12:51:49 +0800
+Subject: [PATCH] LF-789-2 arm64: dts: add overlay support for ls1028a-qds
+
+Now seems only ls1028a-qds using overlay by adding fragment dtbs.
+Add their support in Makefile.
+
+This is one of approach suggested by DT maintainer Rob here:
+https://lore.kernel.org/patchwork/patch/821645/
+
+Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
+Signed-off-by: Jason Liu <jason.hui.liu@nxp.com>
+Reviewed-by: Alex Marginean <alexandru.marginean@nxp.com>
+Tested-by: Alex Marginean <alexandru.marginean@nxp.com>
+---
+ arch/arm64/boot/dts/freescale/Makefile | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+--- a/arch/arm64/boot/dts/freescale/Makefile
++++ b/arch/arm64/boot/dts/freescale/Makefile
+@@ -1,4 +1,14 @@
+ # SPDX-License-Identifier: GPL-2.0
++
++# required for overlay support
++DTC_FLAGS_fsl-ls1028a-qds := -@
++DTC_FLAGS_fsl-ls1028a-qds-13bb := -@
++DTC_FLAGS_fsl-ls1028a-qds-65bb := -@
++DTC_FLAGS_fsl-ls1028a-qds-7777 := -@
++DTC_FLAGS_fsl-ls1028a-qds-85bb := -@
++DTC_FLAGS_fsl-ls1028a-qds-899b := -@
++DTC_FLAGS_fsl-ls1028a-qds-9999 := -@
++
+ dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1012a-2g5rdb.dtb
+ dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1012a-frdm.dtb
+ dtb-$(CONFIG_ARCH_LAYERSCAPE) += fsl-ls1012a-frwy.dtb