ramips: 5.10: port and refresh patches, ralink drv
[openwrt/staging/wigyori.git] / target / linux / ramips / patches-5.10 / 802-GPIO-MIPS-ralink-add-gpio-driver-for-ralink-SoC.patch
index eae507bcd7b608cb2dd90b0b14acd67ef57e10cf..141d29f9401ca67be8c8a80b2e094d287a6e2e8d 100644 (file)
@@ -47,7 +47,7 @@ Cc: linux-gpio@vger.kernel.org
 +#endif /* __ASM_MACH_RALINK_GPIO_H */
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -471,6 +471,12 @@ config GPIO_SNPS_CREG
+@@ -535,6 +535,12 @@ config GPIO_SNPS_CREG
          where only several fields in register belong to GPIO lines and
          each GPIO line owns a field with different length and on/off value.
  
@@ -62,7 +62,7 @@ Cc: linux-gpio@vger.kernel.org
        depends on PLAT_SPEAR
 --- a/drivers/gpio/Makefile
 +++ b/drivers/gpio/Makefile
-@@ -112,6 +112,7 @@ obj-$(CONFIG_GPIO_PISOSR)          += gpio-pisos
+@@ -119,6 +119,7 @@ obj-$(CONFIG_GPIO_PISOSR)          += gpio-pisos
  obj-$(CONFIG_GPIO_PL061)              += gpio-pl061.o
  obj-$(CONFIG_GPIO_PMIC_EIC_SPRD)      += gpio-pmic-eic-sprd.o
  obj-$(CONFIG_GPIO_PXA)                        += gpio-pxa.o