finally move buildroot-ng to trunk
[openwrt/staging/wigyori.git] / target / linux / sibyte-2.6 / Makefile
diff --git a/target/linux/sibyte-2.6/Makefile b/target/linux/sibyte-2.6/Makefile
new file mode 100644 (file)
index 0000000..30fa1a8
--- /dev/null
@@ -0,0 +1,22 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+LINUX_VERSION:=2.6.17
+LINUX_RELEASE:=1
+LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+
+include ./config
+include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/kernel-build.mk
+
+$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
+       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
+       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
+       @$(CP) config $(LINUX_DIR)/.config
+       touch $@
+