uml: clean up the kernel config and add squashfs+ext4/f2fs support
[openwrt/staging/wigyori.git] / target / linux / uml / image / Makefile
index 5e7247ecdd5976cb63adbc2ad6998c37e9da786d..8e83bfeecc3c19057c6234c5e7057194a9c59925 100644 (file)
@@ -11,7 +11,12 @@ define Image/Prepare
        cp $(LINUX_DIR)/linux $(KDIR)/vmlinux.elf
 endef
 
+define Image/Build/squashfs
+       dd if=/dev/zero of=$(KDIR)/root.squashfs bs=1024k count=0 seek=$(CONFIG_TARGET_ROOTFS_PARTSIZE)
+endef
+
 define Image/Build
+       $(call Image/Build/$(1))
        cp $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
        cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux
 endef