toolchain: remove gcc libssp and use libc variant
[openwrt/staging/wigyori.git] / toolchain / glibc / common.mk
index db4f0fcc0e22a9f4e197889b0868e4e86e338e6c..f0b95d3cc730ef62df5499701531cd7e5a8efd31 100644 (file)
@@ -39,7 +39,6 @@ ifeq ($(ARCH),mips64)
   endif
 endif
 
-
 # -Os miscompiles w. 2.24 gcc5/gcc6
 # only -O2 tested by upstream changeset
 # "Optimize i386 syscall inlining for GCC 5"
@@ -61,6 +60,8 @@ GLIBC_CONFIGURE:= \
                --without-cvs \
                --enable-add-ons \
                --$(if $(CONFIG_SOFT_FLOAT),without,with)-fp \
+                 $(if $(CONFIG_PKG_CC_STACKPROTECTOR_REGULAR),--enable-stack-protector=yes) \
+                 $(if $(CONFIG_PKG_CC_STACKPROTECTOR_STRONG),--enable-stack-protector=strong) \
                --enable-kernel=4.14.0
 
 export libc_cv_ssp=no