build: rework opkg command invocation
[openwrt/staging/yousong.git] / include / rootfs.mk
index 4b4482c2131bd3e6bc503aa50bee25bd6a69c635..90ee3126195d6c43a518c95a55036229d46886a3 100644 (file)
@@ -34,11 +34,11 @@ ifdef CONFIG_USE_MKLIBS
 endif
 
 # where to build (and put) .ipk packages
-OPKG:= \
+opkg = \
   IPKG_NO_SCRIPT=1 \
-  IPKG_INSTROOT=$(TARGET_DIR) \
-  $(XARGS) $(STAGING_DIR_HOST)/bin/opkg \
-       --offline-root $(TARGET_DIR) \
+  IPKG_INSTROOT=$(1) \
+  $(STAGING_DIR_HOST)/bin/opkg \
+       --offline-root $(1) \
        --force-depends \
        --force-overwrite \
        --force-postinstall \