packages: bump uboot-sunxi to enable H3 support
[openwrt/staging/yousong.git] / package / boot / uboot-sunxi / Makefile
index b08f9ed1df0fc85801b5c11ff20024e5a73708ca..8471bb3cf4735420dc8ca8051eceebef294fe87c 100644 (file)
@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=u-boot
-PKG_VERSION:=2015.07
+PKG_VERSION:=2016.01-rc2
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        http://mirror2.openwrt.org/sources \
        ftp://ftp.denx.de/pub/u-boot
 
-PKG_MD5SUM:=3dac9a0b46fed77fc768ad3bd2d68c05
+PKG_MD5SUM:=aca6c7a38534812ab529e90aae976422
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -66,6 +66,10 @@ define uboot/Cubietruck
   TITLE:=U-Boot for Cubietruck
 endef
 
+define uboot/Hummingbird_A31
+  TITLE:=U-Boot for the Hummingbird A31 board
+endef
+
 define uboot/Mele_M9
   TITLE:=U-Boot for the Mele M9 (A31)
 endef
@@ -86,6 +90,10 @@ define uboot/Lamobo_R1
   TITLE:=U-Boot for Lamobo R1
 endef
 
+define uboot/orangepi_plus
+  TITLE:=U-Boot for Orange Pi Plus (H3)
+endef
+
 UBOOTS:= \
        A10-OLinuXino-Lime \
        A13-OLinuXino \
@@ -96,11 +104,13 @@ UBOOTS:= \
        Cubieboard \
        Cubieboard2 \
        Cubietruck \
+       Hummingbird_A31 \
        Mele_M9 \
        OLIMEX_A13_SOM \
        Linksprite_pcDuino \
        Linksprite_pcDuino3 \
        Lamobo_R1 \
+       orangepi_plus
 
 define Package/uboot/template
 define Package/uboot-sunxi-$(1)