opkg: set PKG_UPGRADE also when running scripts for the old package
[openwrt/staging/yousong.git] / package / system / opkg / patches / 007-force_static.patch
index 38cdb7a86927fdc604163d01edf02b043d9c06a9..74977070c3f9a81a2a9fa14a9f779176059df6cd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/libopkg/Makefile.am
 +++ b/libopkg/Makefile.am
-@@ -38,16 +38,10 @@
+@@ -38,16 +38,10 @@ if HAVE_SHA256
  opkg_util_sources += sha256.c sha256.h
  endif
  
@@ -22,7 +22,7 @@
 +libopkg_a_LIBADD = $(top_builddir)/libbb/libbb.a
 --- a/libbb/Makefile.am
 +++ b/libbb/Makefile.am
-@@ -2,9 +2,9 @@
+@@ -2,9 +2,9 @@ HOST_CPU=@host_cpu@
  BUILD_CPU=@build_cpu@
  ALL_CFLAGS=-g -O -Wall -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@
  
@@ -36,7 +36,7 @@
        wfopen.c \
 --- a/tests/Makefile.am
 +++ b/tests/Makefile.am
-@@ -4,11 +4,11 @@
+@@ -4,11 +4,11 @@ AM_CFLAGS = $(ALL_CFLAGS) -Wall -g -O3 -
  #noinst_PROGRAMS = libopkg_test opkg_active_list_test
  noinst_PROGRAMS = libopkg_test
  
@@ -50,7 +50,7 @@
  #opkg_extract_test_SOURCES = opkg_extract_test.c
  #opkg_extract_test_CFLAGS = $(ALL_CFLAGS) -I$(top_srcdir)
  
-@@ -16,7 +16,7 @@
+@@ -16,7 +16,7 @@ noinst_PROGRAMS = libopkg_test
  #opkg_active_list_test_SOURCES = opkg_active_list_test.c
  #opkg_active_list_test_CFLAGS = $(ALL_CFLAGS) -I$(top_srcdir)
  
@@ -61,7 +61,7 @@
  
 --- a/src/Makefile.am
 +++ b/src/Makefile.am
-@@ -2,5 +2,5 @@
+@@ -2,5 +2,5 @@ AM_CFLAGS = -I${top_srcdir}/libopkg ${AL
  bin_PROGRAMS = opkg-cl
  
  opkg_cl_SOURCES = opkg-cl.c