armvirt: new target
[openwrt/staging/yousong.git] / target / linux / armvirt / Makefile
diff --git a/target/linux/armvirt/Makefile b/target/linux/armvirt/Makefile
new file mode 100644 (file)
index 0000000..b91e932
--- /dev/null
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2016 Yousong Zhou <yszhou4tech@gmail.com>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=armvirt
+BOARDNAME:=QEMU ARM Virtual Machine
+FEATURES:=fpu pci rtc
+FEATURES+=cpiogz ext4 ramdisk squashfs targz
+CPU_TYPE:=cortex-a15
+CPU_SUBTYPE:=neon-vfpv4
+MAINTAINER:=Yousong Zhou <yszhou4tech@gmail.com>
+
+KERNEL_PATCHVER:=4.4
+
+define Target/Description
+  Build images for QEMU ARM Virtual Machine
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=zImage
+
+$(eval $(call BuildTarget))