bcm53xx: add Linux 4.9 patches
[openwrt/staging/yousong.git] / target / linux / bcm53xx / patches-4.9 / 032-0008-ARM-BCM5301X-Add-DT-for-Luxul-XAP-1410.patch
diff --git a/target/linux/bcm53xx/patches-4.9/032-0008-ARM-BCM5301X-Add-DT-for-Luxul-XAP-1410.patch b/target/linux/bcm53xx/patches-4.9/032-0008-ARM-BCM5301X-Add-DT-for-Luxul-XAP-1410.patch
new file mode 100644 (file)
index 0000000..3592f70
--- /dev/null
@@ -0,0 +1,89 @@
+From eeacbb3e30f220d5d775c61421f813d4e186a325 Mon Sep 17 00:00:00 2001
+From: Dan Haab <dhaab@luxul.com>
+Date: Sat, 14 Jan 2017 19:29:27 -0700
+Subject: [PATCH] ARM: BCM5301X: Add DT for Luxul XAP-1410
+
+Luxul XAP-1410 in a dual-band access point device based on BCM47081 with
+serial flash. It has 3 LEDs and just one (reset) button.
+
+Signed-off-by: Dan Haab <dhaab@luxul.com>
+Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
+---
+ arch/arm/boot/dts/Makefile                    |  1 +
+ arch/arm/boot/dts/bcm47081-luxul-xap-1410.dts | 60 +++++++++++++++++++++++++++
+ 2 files changed, 61 insertions(+)
+ create mode 100644 arch/arm/boot/dts/bcm47081-luxul-xap-1410.dts
+
+--- a/arch/arm/boot/dts/Makefile
++++ b/arch/arm/boot/dts/Makefile
+@@ -73,6 +73,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+       bcm47081-asus-rt-n18u.dtb \
+       bcm47081-buffalo-wzr-600dhp2.dtb \
+       bcm47081-buffalo-wzr-900dhp.dtb \
++      bcm47081-luxul-xap-1410.dtb \
+       bcm4709-asus-rt-ac87u.dtb \
+       bcm4709-buffalo-wxr-1900dhp.dtb \
+       bcm4709-netgear-r7000.dtb \
+--- /dev/null
++++ b/arch/arm/boot/dts/bcm47081-luxul-xap-1410.dts
+@@ -0,0 +1,60 @@
++/*
++ * Copyright 2017 Luxul Inc.
++ *
++ * Licensed under the ISC license.
++ */
++
++/dts-v1/;
++
++#include "bcm47081.dtsi"
++
++/ {
++      compatible = "luxul,xap-1410v1", "brcm,bcm47081", "brcm,bcm4708";
++      model = "Luxul XAP-1410 V1";
++
++      chosen {
++              bootargs = "console=ttyS0,115200";
++      };
++
++      memory {
++              reg = <0x00000000 0x08000000>;
++      };
++
++      leds {
++              compatible = "gpio-leds";
++
++              5ghz {
++                      label = "bcm53xx:blue:5ghz";
++                      gpios = <&chipcommon 13 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "none";
++              };
++
++              2ghz {
++                      label = "bcm53xx:blue:2ghz";
++                      gpios = <&chipcommon 14 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "none";
++              };
++
++              status {
++                      label = "bcm53xx:green:status";
++                      gpios = <&chipcommon 15 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "timer";
++              };
++      };
++
++      gpio-keys {
++              compatible = "gpio-keys";
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              restart {
++                      label = "Reset";
++                      linux,code = <KEY_RESTART>;
++                      gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
++              };
++      };
++};
++
++&spi_nor {
++      status = "okay";
++};