gemini: drop Linux 4.1 support
[openwrt/staging/yousong.git] / target / linux / gemini / patches / 110-watchdog-add-gemini_wdt-driver.patch
diff --git a/target/linux/gemini/patches/110-watchdog-add-gemini_wdt-driver.patch b/target/linux/gemini/patches/110-watchdog-add-gemini_wdt-driver.patch
new file mode 100644 (file)
index 0000000..bb66ae4
--- /dev/null
@@ -0,0 +1,29 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -229,6 +229,16 @@ config 977_WATCHDOG
+         Not sure? It's safe to say N.
++config GEMINI_WATCHDOG
++      tristate "Gemini watchdog"
++      depends on ARCH_GEMINI
++      help
++        Say Y here if to include support for the watchdog timer
++        embedded in the Cortina Systems Gemini family of devices.
++
++        To compile this driver as a module, choose M here: the
++        module will be called gemini_wdt.
++
+ config IXP4XX_WATCHDOG
+       tristate "IXP4xx Watchdog"
+       depends on ARCH_IXP4XX
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -37,6 +37,7 @@ obj-$(CONFIG_OMAP_WATCHDOG) += omap_wdt.
+ obj-$(CONFIG_TWL4030_WATCHDOG) += twl4030_wdt.o
+ obj-$(CONFIG_21285_WATCHDOG) += wdt285.o
+ obj-$(CONFIG_977_WATCHDOG) += wdt977.o
++obj-$(CONFIG_GEMINI_WATCHDOG) += gemini_wdt.o
+ obj-$(CONFIG_IXP4XX_WATCHDOG) += ixp4xx_wdt.o
+ obj-$(CONFIG_KS8695_WATCHDOG) += ks8695_wdt.o
+ obj-$(CONFIG_S3C2410_WATCHDOG) += s3c2410_wdt.o