ramips: Add support to TP-Link Archer MR200
[openwrt/staging/yousong.git] / target / linux / ramips / image / mt7620.mk
index 0bd6c9dcd80441d75517e32e9c04845027f9dbfe..d0e89b68a2b34ec690323a15fd5a92c63de4fc14 100644 (file)
@@ -59,6 +59,16 @@ define Device/ArcherC50
 endef
 TARGET_DEVICES += ArcherC50
 
+define Device/ArcherMR200
+  DTS := ArcherMR200
+  KERNEL := $(KERNEL_DTB)
+  KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherMR200 -c
+  IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherMR200 -j -r $(KDIR)/root.squashfs
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-net kmod-usb-net-rndis kmod-usb-serial kmod-usb-serial-option adb
+  DEVICE_TITLE := TP-Link ArcherMR200
+endef
+TARGET_DEVICES += ArcherMR200
+
 define Device/ex2700
   DTS := EX2700
   BLOCKSIZE := 4k