add a stripped down (and portable) version of flock to the host tools
[openwrt/staging/yousong.git] / tools / flock / Makefile
diff --git a/tools/flock/Makefile b/tools/flock/Makefile
new file mode 100644 (file)
index 0000000..64a8655
--- /dev/null
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2006-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME := flock
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+       mkdir -p $(HOST_BUILD_DIR)
+       $(HOSTCC) $(HOST_CFLAGS) -o $(HOST_BUILD_DIR)/flock src/flock.c
+endef
+
+define Host/Install
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/flock $(STAGING_DIR_HOST)/bin/
+endef
+
+$(eval $(call HostBuild))