tools: Fix compilation on x32 host
[openwrt/staging/yousong.git] / tools / gmp / Makefile
index 463cbe9f5c4f1d47bfa942c3e51299d4bca5f331..b1976d0cc3db77adb9c3a7d4ed8710c45308abc8 100644 (file)
@@ -27,4 +27,8 @@ HOST_CONFIGURE_ARGS += \
        --enable-cxx \
        --enable-mpbsd
 
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += ABI=x32
+endif
+
 $(eval $(call HostBuild))