build: for cmake, always use ccache from staging dir instead of relying on the host
[openwrt/svn-archive/archive.git] / include / cmake.mk
index 4207a4dcee8444ac1472b2b78a068e5ed811c7ae..4e4169a132c71f21c99d24d3af81b0e3d8837a70 100644 (file)
@@ -18,10 +18,7 @@ ifeq ($(CONFIG_CCACHE),)
  CMAKE_C_COMPILER_ARG1:=
  CMAKE_CXX_COMPILER_ARG1:=
 else
-  CCACHE:=$(shell which ccache)
-  ifeq ($(CCACHE),)
-    CCACHE:=$(STAGING_DIR_HOST)/bin/ccache
-  endif
+  CCACHE:=$(STAGING_DIR_HOST)/bin/ccache
   CMAKE_C_COMPILER:=$(CCACHE)
   CMAKE_C_COMPILER_ARG1:=$(TARGET_CC_NOCACHE)
   CMAKE_CXX_COMPILER:=$(CCACHE)