build: add the + token to any commands that can pass through the jobserver, fixes...
[openwrt/svn-archive/archive.git] / include / host-build.mk
index 66795c8e1082c848a941dc09c87abd113a7e1387..60b7b9f916df771899038d1e3adecfced8d2ccad 100644 (file)
@@ -80,7 +80,7 @@ ifneq ($(HOST_OS),Darwin)
 endif
 
 define Host/Configure/Default
 endif
 
 define Host/Configure/Default
-       (cd $(HOST_BUILD_DIR)/$(3); \
+       $(if $(HOST_CONFIGURE_PARALLEL),+)(cd $(HOST_BUILD_DIR)/$(3); \
                if [ -x configure ]; then \
                        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/$(3)/ && \
                        $(2) \
                if [ -x configure ]; then \
                        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/$(3)/ && \
                        $(2) \
@@ -97,7 +97,7 @@ define Host/Configure
 endef
 
 define Host/Compile/Default
 endef
 
 define Host/Compile/Default
-       $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) \
+       +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) \
                $(HOST_MAKE_FLAGS) \
                $(1)
 endef
                $(HOST_MAKE_FLAGS) \
                $(1)
 endef