build: BSD compile fixes
[openwrt/svn-archive/archive.git] / include / host.mk
index 9b8a32b672d3579c5cbe1deed2f7625dec912e0a..b44c1bf1ac6f3a9a1af9f865e48613a0d87d5ec4 100644 (file)
@@ -62,6 +62,9 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                PATCH=`which gpatch 2>/dev/null`; \
                [ -n "$$PATCH" -a -x "$$PATCH" ] || PATCH=`which patch 2>/dev/null`; \
                echo "PATCH:=$$PATCH" >> $@; \
+               PYTHON=`which python2.7 2>/dev/null`; \
+               [ -n "$$PYTHON" -a -x "$$PYTHON" ] || PYTHON=`which python 2>/dev/null`; \
+               echo "PYTHON:=$$PYTHON" >> $@; \
        )
 
 endif