build: add a dependency on libc to all non-kernel packages
[openwrt/svn-archive/archive.git] / include / package-defaults.mk
index 75442925f1f391c75b2c828be2011e97bce67a96..c3496767cf7fd53f8a837276c23e95f6b6913234 100644 (file)
@@ -5,6 +5,12 @@
 # See /LICENSE for more information.
 #
 
+ifneq ($(PKG_NAME),toolchain)
+  PKG_FIXUP_DEPENDS = $(if $(filter kmod-%,$(1)),$(2),+libc $(filter-out +libc,$(2)))
+else
+  PKG_FIXUP_DEPENDS = $(2)
+endif
+
 define Package/Default
   CONFIGFILE:=
   SECTION:=opt