prereq: stop relying on man pages and grep for --recursive on the git-submodule scrip...
[openwrt/svn-archive/archive.git] / include / prereq-build.mk
index a93dd63ab5385535f507be41dfcc6aef774f56d1..a53065576cc9c15295fb3e12d541053d45907ac2 100644 (file)
@@ -155,7 +155,7 @@ $(eval $(call SetupHostCommand,svn,Please install the Subversion client, \
        svn --version | grep Subversion))
 
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
-       MANPAGER=cat git submodule --help 2>&1 | grep -q -- --recursive))
+       git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))
 
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
        file --version 2>&1 | grep file))