eliminate redundancy by creating the quilt_used stampfile in the right place
[openwrt/svn-archive/archive.git] / include / quilt.mk
index 4323c77b2b4f8990d21caa4690609581dc600623..77b76a6daee91d6dec0a2ff7e67942e68514486b 100644 (file)
@@ -79,11 +79,13 @@ endif
 define Host/Patch/Default
        $(if $(QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
        $(call PatchDir,$(HOST_BUILD_DIR),$(PATCH_DIR),)
+       $(if $(QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
 endef
 
 define Build/Patch/Default
        $(if $(QUILT),rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches)
        $(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR),)
+       $(if $(QUILT),touch $(PKG_BUILD_DIR)/.quilt_used)
 endef
 
 kernel_files=$(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.)