tools: add scons (patch by Dave Taht)
[openwrt/svn-archive/archive.git] / include / scons.mk
diff --git a/include/scons.mk b/include/scons.mk
new file mode 100644 (file)
index 0000000..223aede
--- /dev/null
@@ -0,0 +1,21 @@
+SCONS_VARS = \
+       CC="$(TARGET_CC)" \
+       CXX="$(TARGET_CXX)" \
+       CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
+       CXXFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
+       CPPFLAGS="$(TARGET_CPPFLAGS) $(EXTRA_CPPFLAGS)" \
+       LDFLAGS="$(TARGET_LDFLAGS) $(EXTRA_LDFLAGS)" \
+       DESTDIR="$(PKG_INSTALL_DIR)"
+
+define Build/Configure/Default
+       (cd $(PKG_BUILD_DIR); \
+               $(SCONS_VARS) \
+               scons \
+                       prefix=/usr \
+                       $(SCONS_OPTIONS) \
+               install \
+       )
+endef
+
+define Build/Compile
+endef