x86-2.6 compile fixes for snapshot build
[openwrt/svn-archive/archive.git] / openwrt / target / linux / package / alsa / Makefile
index eea05a074850826f8e0fe573ae80516bb562a213..02baa44b3457b62d5a36339ce45f87cb4da2ede7 100644 (file)
@@ -21,7 +21,7 @@ endif
 include $(TOPDIR)/package/rules.mk
 
 ifeq ($(LINUX_KARCH),i386)
-KERNEL_C_INCS:=
+KERNEL_C_INCS:= -I$(KERNEL_DIR)/include/asm-i386/mach-generic
 KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time
 endif
 ifeq ($(LINUX_KARCH),mips)