update to new version, fixes bug #153
[openwrt/svn-archive/archive.git] / openwrt / target / linux / package / spca5xx / patches / 01-kmod-build.patch
index eb7dccd32e5d19b0bf595a5850b6dc1559e13401..304df920475b1a7e1e167729e2e2688c4011dc86 100644 (file)
@@ -1,6 +1,6 @@
-diff -ruN spca5xx-20051105-old/Makefile spca5xx-20051105-new/Makefile
---- spca5xx-20051105-old/Makefile      2005-11-05 19:18:26.000000000 +0100
-+++ spca5xx-20051105-new/Makefile      2005-12-09 10:34:47.000000000 +0100
+diff -Nur spca5xx-20051212/Makefile spca5xx-20051212.patched/Makefile
+--- spca5xx-20051212/Makefile  2005-12-10 17:05:51.000000000 +0100
++++ spca5xx-20051212.patched/Makefile  2005-12-25 02:41:29.910720750 +0100
 @@ -33,7 +33,9 @@
  DEFINES   += -DCONFIG_USB_SPCA5XX_MODULE=1 -DMODULE -D__KERNEL__
  DEFINES   += -DVID_HARDWARE_SPCA5XX=0xFF -DSPCA5XX_VERSION=\"$(VERSION)\"
@@ -12,7 +12,7 @@ diff -ruN spca5xx-20051105-old/Makefile spca5xx-20051105-new/Makefile
  
  ifneq ($(KERNELRELEASE),)   # We were called by kbuild
  CFLAGS += $(DEFINES) 
-@@ -68,158 +70,19 @@
+@@ -68,152 +70,16 @@
  
  else   # kernel version test
  
@@ -26,11 +26,9 @@ diff -ruN spca5xx-20051105-old/Makefile spca5xx-20051105-new/Makefile
 -# This makefile will build the spca50x driver module external to the kernel
 -# source tree. It makes it easier to swap kernels.
 -
-+EXTRA_CFLAGS += $(DEFINES) 
+-
 -KERNEL_VERSION = `uname -r`
-+spca5xx-objs := drivers/usb/spca5xx.o drivers/usb/spcadecoder.o 
+-
 -###
 -# Location of the header files (most importantly the config files)
 -# for the kernel you want to build the module against.
@@ -44,15 +42,12 @@ diff -ruN spca5xx-20051105-old/Makefile spca5xx-20051105-new/Makefile
 -ifneq ($(strip $(shell grep 'define CONFIG_MODVERSIONS 1' $(KERNEL_ACFILE))),)
 -      DEFINES += -DMODVERSIONS -include $(KERNEL_MODVERSIONSFILE)
 -endif
-+obj-m += spca5xx.o
-+obj-y := $(spca5xx-objs)
+-
 -# Detect SMP support
 -ifneq ($(strip $(shell grep 'define CONFIG_SMP 1' $(KERNEL_ACFILE))),)
 -      DEFINES += -D__SMP__ -DSMP
 -endif
-+O_TARGET := $(obj-m)
+-
 -# Setup the tools
 -CC         = gcc
 -LD         = ld
@@ -77,8 +72,6 @@ diff -ruN spca5xx-20051105-old/Makefile spca5xx-20051105-new/Makefile
 -             drivers/usb/Config.in \
 -             drivers/usb/spcadecoder.c \
 -             drivers/usb/spcadecoder.h \
--             drivers/usb/jpeg_header.h \
--           drivers/usb/jpeg_qtables.h \
 -           drivers/usb/spcagamma.h \
 -           drivers/usb/spcaCompat.h \
 -           drivers/usb/spcausb.h \
@@ -168,12 +161,17 @@ diff -ruN spca5xx-20051105-old/Makefile spca5xx-20051105-new/Makefile
 -
 -drivers/usb/spcadecoder.o: drivers/usb/spcadecoder.h \
 -                         drivers/usb/spcagamma.h \
--                           drivers/usb/jpeg_header.h
+-                          
++EXTRA_CFLAGS += $(DEFINES) 
++  
++spca5xx-objs := drivers/usb/spca5xx.o drivers/usb/spcadecoder.o 
++  
++obj-m += spca5xx.o
++obj-y := $(spca5xx-objs)
++  
++O_TARGET := $(obj-m)
++  
 +-include $(TOPDIR)/Rules.make
  
  endif  # End kernel version test
  
--
- ############################################################################## 
- # OTHER TARGETS 
- ##############################################################################