load kernel modules in kmod- packages from postinst scripts at install.
[openwrt/svn-archive/archive.git] / openwrt / target / linux / rules.mk
index 3358f1fd930acee1911ea9702d5cf5d52ce48345..ae557f26b4a38449358f7efeeb0b9ce6f57c13de 100644 (file)
@@ -76,6 +76,11 @@ ifneq ($(6),)
        for module in $(7); do \
                echo $$$$module >> $$(I_$(1))/etc/modules.d/$(6)-$(2); \
        done
+       echo "#!/bin/sh" >> $$(I_$(1))/CONTROL/postinst
+       echo "[ -z \"\$$$$IPKG_INSTROOT\" ] || exit" >> $$(I_$(1))/CONTROL/postinst
+       echo ". /etc/functions.sh" >> $$(I_$(1))/CONTROL/postinst
+       echo "load_modules /etc/modules.d/$(6)-$(2)" >> $$(I_$(1))/CONTROL/postinst
+       chmod 0755 $$(I_$(1))/CONTROL/postinst
 endif
        $(8)
        $(IPKG_BUILD) $$(I_$(1)) $(PACKAGE_DIR) $(MAKE_TRACE)