make gcc4 depend on libgcc, and disable the libgcc hack for it
[openwrt/svn-archive/archive.git] / openwrt / toolchain / gcc / Makefile
index 2d24cdd13e2b2e507c9a720df172adc5d91097fe..26e17ad61e28ad31a7e8b2433a446907d4a81e68 100644 (file)
@@ -193,11 +193,7 @@ endif
 # We do another ugly hack here because the standard behaviour is
 # to include a reference to libgcc.so.1 in all binaries. For flash space
 # saving, we change the specs file to link in a static libgcc here. 
-       if [ ! -f $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs ] ; then \
-               echo staging dir specs file is missing, assuming GCC 4.x ; \
-               $(STAGING_DIR)/bin/$(REAL_GNU_TARGET_NAME)-gcc -dumpspecs > $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs; \
-       fi;
-       if grep -q as-needed $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs; then \
+       if [ -f $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/specs ] ; then \
                patch -d $(STAGING_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)/ -p0 < ./$(GCC_VERSION)/static-libgcc.patch.conditional ; \
        fi;