base-files: allow timezone to be overriden by zonename (proper zoneinfo support)
[openwrt/svn-archive/archive.git] / package / base-files / Makefile
index 1367fa929142c21f893b991fc4c398c444ce8249..bf32f6306a4ca574d6282bc6a76aa9351d49f15c 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=164
+PKG_RELEASE:=165
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=usign/host
@@ -161,7 +161,7 @@ define Package/base-files/install
        rm -f $(1)/var
        $(LN) /tmp $(1)/var
        mkdir -p $(1)/etc
-       $(LN) /tmp/resolv.conf /tmp/fstab /tmp/TZ $(1)/etc/
+       $(LN) /tmp/resolv.conf /tmp/fstab /tmp/TZ /tmp/localtime $(1)/etc/
 
        chmod 0600 $(1)/etc/shadow
        chmod 1777 $(1)/tmp