[package] crda: make the whole crypto stuff optional and don't use it for now, link...
[openwrt/svn-archive/archive.git] / package / crda / patches / 101-make_crypto_use_optional.patch
diff --git a/package/crda/patches/101-make_crypto_use_optional.patch b/package/crda/patches/101-make_crypto_use_optional.patch
new file mode 100644 (file)
index 0000000..105ffb3
--- /dev/null
@@ -0,0 +1,13 @@
+--- a/Makefile
++++ b/Makefile
+@@ -29,7 +29,9 @@ LDLIBS += `pkg-config --libs openssl`
+ reglib.o: keys-ssl.c
+-else
++endif
++
++ifeq ($(USE_GCRYPT),1)
+ CFLAGS += -DUSE_GCRYPT
+ LDLIBS += -lgcrypt