package/grub: fix compile issue under FreeBSD 8.1
[openwrt/svn-archive/archive.git] / package / grub / Makefile
index 426b9c367307fc5ede8d1dad88f80bb420ea5e1e..f3dd171141b9436474561970b8a5762d2d685af8 100644 (file)
@@ -37,6 +37,10 @@ MY_CONFIGURE_ARGS += \
        --disable-hercules \
        --without-curses \
 
+ifeq ($(HOST_OS),FreeBSD)
+  MY_CONFIGURE_ARGS += --build=$(GNU_HOST_NAME) --host=$(GNU_TARGET_NAME) --target=$(GNU_TARGET_NAME)
+endif
+
 MY_CONFIGURE_VARS += \
        grub_cv_prog_objcopy_absolute=yes \