kernel: adjust orion/kirkwood packages to also build for mvebu target
[openwrt/svn-archive/archive.git] / package / kernel / modules / i2c.mk
index 0a4982010c89bd7101c791c8c43383e8f96d7edf..2ee73bfca9dcc13391eafc324e138f69dde2fbef 100644 (file)
@@ -154,11 +154,11 @@ I2C_MV64XXX_MODULES:=\
 define KernelPackage/i2c-mv64xxx
   $(call i2c_defaults,$(I2C_MV64XXX_MODULES),59)
   TITLE:=Orion Platform I2C interface support
-  DEPENDS:=@TARGET_kirkwood||TARGET_orion +kmod-i2c-core
+  DEPENDS:=@TARGET_kirkwood||TARGET_orion||TARGET_mvebu +kmod-i2c-core
 endef
 
 define KernelPackage/i2c-mv64xxx/description
- Kernel module for I2C interface on the Kirkwood and Orion
+ Kernel module for I2C interface on the Kirkwood, Orion and Armada XP/370
  family processors.
 endef