mac80211: update to wireless-testing 2013-06-13 + latest backport infrastructure
[openwrt/svn-archive/archive.git] / package / mac80211 / patches / 400-ath_move_debug_code.patch
index c91128db61d994988b6c4700acfd6c718ab81913..a01db3ea9bcf37e6b12e2de429f1214266b869e1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/ath/Makefile
 +++ b/drivers/net/wireless/ath/Makefile
-@@ -10,7 +10,7 @@ obj-$(CONFIG_ATH_COMMON)     += ath.o
+@@ -11,7 +11,7 @@ obj-$(CPTCFG_ATH_COMMON)     += ath.o
  ath-objs :=   main.o \
                regd.o \
                hw.o \
@@ -8,15 +8,15 @@
 +              key.o \
 +              debug.o
  
--ath-$(CONFIG_ATH_DEBUG) += debug.o
+-ath-$(CPTCFG_ATH_DEBUG) += debug.o
  ccflags-y += -D__CHECK_ENDIAN__
 --- a/drivers/net/wireless/ath/ath.h
 +++ b/drivers/net/wireless/ath/ath.h
 @@ -281,13 +281,6 @@ void _ath_dbg(struct ath_common *common,
- #endif /* CONFIG_ATH_DEBUG */
+ #endif /* CPTCFG_ATH_DEBUG */
  
  /** Returns string describing opmode, or NULL if unknown mode. */
--#ifdef CONFIG_ATH_DEBUG
+-#ifdef CPTCFG_ATH_DEBUG
  const char *ath_opmode_to_string(enum nl80211_iftype opmode);
 -#else
 -static inline const char *ath_opmode_to_string(enum nl80211_iftype opmode)