refresh patches, make madwifi-dfs compile on linux 2.4 again
[openwrt/svn-archive/archive.git] / package / madwifi / patches / 200-no_debug.patch
index c7aeaae0eaf3157704e86d7e27dae0b3af0f39d0..a54b33d529db6510598a1c23ed63569df66b0eaa 100644 (file)
@@ -1,7 +1,7 @@
-Index: madwifi-dfs-r2996/ath/if_ath.c
+Index: madwifi-dfs-r3053/ath/if_ath.c
 ===================================================================
---- madwifi-dfs-r2996.orig/ath/if_ath.c        2007-12-01 18:53:03.204271791 +0100
-+++ madwifi-dfs-r2996/ath/if_ath.c     2007-12-01 18:53:28.557716602 +0100
+--- madwifi-dfs-r3053.orig/ath/if_ath.c        2007-12-13 05:25:13.122373270 +0100
++++ madwifi-dfs-r3053/ath/if_ath.c     2007-12-13 05:25:13.342385808 +0100
 @@ -42,7 +42,7 @@
   * This software is derived from work of Atsushi Onoe; his contribution
   * is greatly appreciated.
@@ -11,7 +11,7 @@ Index: madwifi-dfs-r2996/ath/if_ath.c
  #include "if_ath_debug.h"
  #include "opt_ah.h"
  
-@@ -515,9 +515,11 @@
+@@ -516,9 +516,11 @@
        u_int8_t csz;
  
        sc->devid = devid;
@@ -23,7 +23,7 @@ Index: madwifi-dfs-r2996/ath/if_ath.c
  
        /*
         * Cache line size is used to size and align various
-@@ -1283,12 +1285,14 @@
+@@ -1280,12 +1282,14 @@
                /* If no default VAP debug flags are passed, allow a few to
                 * transfer down from the driver to new VAPs so we can have load
                 * time debugging for VAPs too. */
@@ -38,7 +38,7 @@ Index: madwifi-dfs-r2996/ath/if_ath.c
        }
        ic->ic_debug = (sc->sc_default_ieee80211_debug & IEEE80211_MSG_IC);
  
-@@ -10290,9 +10294,11 @@
+@@ -10308,9 +10312,11 @@
                                /* XXX validate? */
                                sc->sc_ledpin = val;
                                break;
@@ -50,7 +50,7 @@ Index: madwifi-dfs-r2996/ath/if_ath.c
                                break;
                        case ATH_TXANTENNA:
                                /*
-@@ -10703,9 +10709,11 @@
+@@ -10721,9 +10727,11 @@
        }
  
        /* initialize values */
@@ -62,10 +62,10 @@ Index: madwifi-dfs-r2996/ath/if_ath.c
        sc->sc_txantenna = 0;           /* default to auto-selection */
        sc->sc_txintrperiod = ATH_TXQ_INTR_PERIOD;
  }
-Index: madwifi-dfs-r2996/ath_rate/amrr/amrr.c
+Index: madwifi-dfs-r3053/ath_rate/amrr/amrr.c
 ===================================================================
---- madwifi-dfs-r2996.orig/ath_rate/amrr/amrr.c        2007-12-01 18:45:14.000000000 +0100
-+++ madwifi-dfs-r2996/ath_rate/amrr/amrr.c     2007-12-01 18:53:06.076435466 +0100
+--- madwifi-dfs-r3053.orig/ath_rate/amrr/amrr.c        2007-12-13 05:25:10.422219395 +0100
++++ madwifi-dfs-r3053/ath_rate/amrr/amrr.c     2007-12-13 05:25:13.342385808 +0100
 @@ -70,7 +70,7 @@
  
  #include "amrr.h"
@@ -75,10 +75,10 @@ Index: madwifi-dfs-r2996/ath_rate/amrr/amrr.c
  #ifdef AMRR_DEBUG
  #define       DPRINTF(sc, _fmt, ...) do {                                     \
        if (sc->sc_debug & 0x10)                                        \
-Index: madwifi-dfs-r2996/ath_rate/minstrel/minstrel.c
+Index: madwifi-dfs-r3053/ath_rate/minstrel/minstrel.c
 ===================================================================
---- madwifi-dfs-r2996.orig/ath_rate/minstrel/minstrel.c        2007-12-01 18:47:14.336390946 +0100
-+++ madwifi-dfs-r2996/ath_rate/minstrel/minstrel.c     2007-12-01 18:53:06.080435695 +0100
+--- madwifi-dfs-r3053.orig/ath_rate/minstrel/minstrel.c        2007-12-13 05:25:12.006309667 +0100
++++ madwifi-dfs-r3053/ath_rate/minstrel/minstrel.c     2007-12-13 05:25:13.350386263 +0100
 @@ -117,7 +117,7 @@
  
  #include "minstrel.h"
@@ -88,10 +88,10 @@ Index: madwifi-dfs-r2996/ath_rate/minstrel/minstrel.c
  #ifdef MINSTREL_DEBUG
  enum {
                ATH_DEBUG_RATE          = 0x00000010    /* rate control */
-Index: madwifi-dfs-r2996/ath_rate/onoe/onoe.c
+Index: madwifi-dfs-r3053/ath_rate/onoe/onoe.c
 ===================================================================
---- madwifi-dfs-r2996.orig/ath_rate/onoe/onoe.c        2007-12-01 18:45:14.000000000 +0100
-+++ madwifi-dfs-r2996/ath_rate/onoe/onoe.c     2007-12-01 18:53:06.080435695 +0100
+--- madwifi-dfs-r3053.orig/ath_rate/onoe/onoe.c        2007-12-13 05:25:10.438220308 +0100
++++ madwifi-dfs-r3053/ath_rate/onoe/onoe.c     2007-12-13 05:25:13.354386489 +0100
 @@ -66,7 +66,7 @@
  
  #include "onoe.h"
@@ -101,10 +101,10 @@ Index: madwifi-dfs-r2996/ath_rate/onoe/onoe.c
  #ifdef ONOE_DEBUG
  enum {
        ATH_DEBUG_RATE  = 0x00000010,   /* rate control */
-Index: madwifi-dfs-r2996/ath_rate/sample/sample.c
+Index: madwifi-dfs-r3053/ath_rate/sample/sample.c
 ===================================================================
---- madwifi-dfs-r2996.orig/ath_rate/sample/sample.c    2007-12-01 18:45:14.000000000 +0100
-+++ madwifi-dfs-r2996/ath_rate/sample/sample.c 2007-12-01 18:53:06.080435695 +0100
+--- madwifi-dfs-r3053.orig/ath_rate/sample/sample.c    2007-12-13 05:25:10.446220763 +0100
++++ madwifi-dfs-r3053/ath_rate/sample/sample.c 2007-12-13 05:25:13.358386718 +0100
 @@ -68,7 +68,7 @@
  
  #include "sample.h"
@@ -114,10 +114,10 @@ Index: madwifi-dfs-r2996/ath_rate/sample/sample.c
  #ifdef SAMPLE_DEBUG
  enum {
        ATH_DEBUG_RATE          = 0x00000010,   /* rate control */
-Index: madwifi-dfs-r2996/tools/do_multi.c
+Index: madwifi-dfs-r3053/tools/do_multi.c
 ===================================================================
---- madwifi-dfs-r2996.orig/tools/do_multi.c    2007-12-01 18:45:51.063645501 +0100
-+++ madwifi-dfs-r2996/tools/do_multi.c 2007-12-01 18:53:06.080435695 +0100
+--- madwifi-dfs-r3053.orig/tools/do_multi.c    2007-12-13 05:25:11.242266126 +0100
++++ madwifi-dfs-r3053/tools/do_multi.c 2007-12-13 05:25:13.362386947 +0100
 @@ -9,16 +9,20 @@
  
      progname = basename(argv[0]);
@@ -139,10 +139,10 @@ Index: madwifi-dfs-r2996/tools/do_multi.c
      if(strcmp(progname, "athkey") == 0)
        ret =  athkey_init(argc, argv);
      if(strcmp(progname, "athstats") == 0)
-Index: madwifi-dfs-r2996/tools/Makefile
+Index: madwifi-dfs-r3053/tools/Makefile
 ===================================================================
---- madwifi-dfs-r2996.orig/tools/Makefile      2007-12-01 18:45:51.067645730 +0100
-+++ madwifi-dfs-r2996/tools/Makefile   2007-12-01 18:53:06.084435926 +0100
+--- madwifi-dfs-r3053.orig/tools/Makefile      2007-12-13 05:25:11.246266355 +0100
++++ madwifi-dfs-r3053/tools/Makefile   2007-12-13 05:25:13.362386947 +0100
 @@ -48,7 +48,7 @@
  
  
@@ -161,10 +161,10 @@ Index: madwifi-dfs-r2996/tools/Makefile
        ln -s -f madwifi_multi $$i; \
        done
  
-Index: madwifi-dfs-r2996/net80211/ieee80211_linux.h
+Index: madwifi-dfs-r3053/net80211/ieee80211_linux.h
 ===================================================================
---- madwifi-dfs-r2996.orig/net80211/ieee80211_linux.h  2007-12-01 18:45:14.000000000 +0100
-+++ madwifi-dfs-r2996/net80211/ieee80211_linux.h       2007-12-01 18:53:06.084435926 +0100
+--- madwifi-dfs-r3053.orig/net80211/ieee80211_linux.h  2007-12-13 05:25:10.470222132 +0100
++++ madwifi-dfs-r3053/net80211/ieee80211_linux.h       2007-12-13 05:25:13.362386947 +0100
 @@ -29,8 +29,8 @@
  #ifndef _NET80211_IEEE80211_LINUX_H_
  #define _NET80211_IEEE80211_LINUX_H_