fix mtd target define for brcm-2.4
[openwrt/svn-archive/archive.git] / package / mtd / Makefile
index 11a78e8454e94164866b52467de1f0c840236693..d8fa19cb0af8259d4a4acc5a1d257ee35f9bfb40 100644 (file)
@@ -35,7 +35,7 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -Dtarget_$(BOARD)=1"
+               CFLAGS="$(TARGET_CFLAGS) -Dtarget_$(firstword $(subst -, ,$(BOARD)))=1"
 endef
 
 define Package/mtd/install