package/u-boot-envtools: update to version 2011.06.
[openwrt/svn-archive/archive.git] / package / uboot-envtools / Makefile
index 32574db69ee8517a26b04a4135892938a4b2e6e4..eaa692142a291df4ac7433605d0ede3fa95d8bd3 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uboot-envtools
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uboot-envtools
-PKG_VERSION:=20081215
-PKG_RELEASE:=2
+PKG_DISTNAME:=u-boot
+PKG_VERSION:=2011.06
+PKG_RELEASE:=1
 
 
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
-PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/u/uboot-envtools/
+PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_MD5SUM:=
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
+TAR_OPTIONS+= --strip-components=3 -C $(PKG_BUILD_DIR) $(PKG_DISTNAME)-$(PKG_VERSION)/tools/env
+
 define Package/uboot-envtools
   SECTION:=utils
   CATEGORY:=Utilities
 define Package/uboot-envtools
   SECTION:=utils
   CATEGORY:=Utilities
@@ -34,4 +38,10 @@ define Package/uboot-envtools/install
        ln -sf fw_printenv $(1)/usr/sbin/fw_setenv
 endef
 
        ln -sf fw_printenv $(1)/usr/sbin/fw_setenv
 endef
 
+define Build/Prepare
+       mkdir -p $(PKG_BUILD_DIR)
+       tar xvjf $(DL_DIR)/$(PKG_SOURCE) --strip-components=2 -C $(PKG_BUILD_DIR) $(PKG_DISTNAME)-$(PKG_VERSION)/lib/crc32.c
+       $(call Build/Prepare/Default)
+endef
+
 $(eval $(call BuildPackage,uboot-envtools))
 $(eval $(call BuildPackage,uboot-envtools))