[uboot-lantiq]
[openwrt/svn-archive/archive.git] / package / uboot-lantiq / patches / 300-arcadyan.patch
index 24ee042159c1af4faf3643d714637379a8ff6c48..92a57a25ca2bf240b39138d10f1fa41e75f36875 100644 (file)
@@ -39,7 +39,7 @@
  SRCS  := $(COBJS:.o=.c)
 --- a/Makefile
 +++ b/Makefile
-@@ -3414,6 +3414,37 @@
+@@ -3414,6 +3414,40 @@
  ## MIPS32 ifxcpe
  #########################################################################
  
 +                      $(XECHO) "... with ramboot configuration" ; \
 +              }
 +      @if [ "$$(findstring flash,$$@)" ] ; then \
++               echo "#TEXT_BASE = 0xB0050000" >$(obj)board/arcadyan/config.tmp ; \
++              echo "#define CONFIG_BOOTSTRAP"  >>$(obj)include/config.h ; \
 +              echo "#define CONFIG_USE_DDR_RAM"  >>$(obj)include/config.h ; \
 +              echo "#define CONFIG_USE_DDR_RAM_CFG_psc166" >>$(obj)include/config.h ; \
 +      fi
 +      @$(MKCONFIG) -a $$(word 1,$$(subst _, ,$$@)) mips mips arcadyan "" danube
 +endef
 +
++$(eval $(call arcadyan, arv3527P%config))
 +$(eval $(call arcadyan, arv4520PW%config))
 +$(eval $(call arcadyan, arv452CPW%config))
 +$(eval $(call arcadyan, arv4525PW%config))