really fix tgz images
[openwrt/svn-archive/archive.git] / target / linux / adm5120-2.6 / image / Makefile
index b9ae44ecb41cb1307be0fe90ac7d3e25993cdaa5..829ddef3da830f4ed2faba9d7c8de1419c3472d0 100644 (file)
@@ -121,10 +121,13 @@ endif
 endif
 endif
 endif
-ifeq ($(1),tgz)
+endef
+
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+  define Image/BuildKernel
        $(call Image/Build/RouterBoard)
+  endef
 endif
-endef
 
 define Image/Build/LZMAKernel
        $(LOADER_MAKE) TARGET_DIR=$(BIN_DIR) \