linux/adm5120: add 2.6.38 preliminary support
[openwrt/svn-archive/archive.git] / target / linux / adm5120 / patches-2.6.38 / 009-adm5120_leds_switch_trigger.patch
diff --git a/target/linux/adm5120/patches-2.6.38/009-adm5120_leds_switch_trigger.patch b/target/linux/adm5120/patches-2.6.38/009-adm5120_leds_switch_trigger.patch
new file mode 100644 (file)
index 0000000..929becb
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -457,4 +457,12 @@ config LEDS_TRIGGER_USBDEV
+         This allows LEDs to be controlled by the presence/activity of
+         an USB device. If unsure, say N.
++config LEDS_TRIGGER_ADM5120_SWITCH
++      tristate "LED ADM5120 Switch Port Status Trigger"
++      depends on LEDS_TRIGGERS && ADM5120
++      help
++        This allows LEDs to be controlled by the port states of
++        the ADM5120 built-in Ethernet Switch
++        If unsure, say N.
++
+ endif # NEW_LEDS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -55,3 +55,4 @@ obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON)        +=
+ obj-$(CONFIG_LEDS_TRIGGER_MORSE)      += ledtrig-morse.o
+ obj-$(CONFIG_LEDS_TRIGGER_NETDEV)     += ledtrig-netdev.o
+ obj-$(CONFIG_LEDS_TRIGGER_USBDEV)     += ledtrig-usbdev.o
++obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o