adm5120: add 3.18 support
[openwrt/svn-archive/archive.git] / target / linux / adm5120 / patches-3.18 / 007-adm5120_pci.patch
diff --git a/target/linux/adm5120/patches-3.18/007-adm5120_pci.patch b/target/linux/adm5120/patches-3.18/007-adm5120_pci.patch
new file mode 100644 (file)
index 0000000..a5a0abf
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_PCI_TX4927)     += ops-tx4927.o
+ obj-$(CONFIG_BCM47XX)         += pci-bcm47xx.o
+ obj-$(CONFIG_BCM63XX)         += pci-bcm63xx.o fixup-bcm63xx.o \
+                                       ops-bcm63xx.o
++obj-$(CONFIG_ADM5120)         += pci-adm5120.o
+ obj-$(CONFIG_MIPS_ALCHEMY)    += pci-alchemy.o
+ obj-$(CONFIG_SOC_AR71XX)      += pci-ar71xx.o
+ obj-$(CONFIG_PCI_AR724X)      += pci-ar724x.o
+--- a/include/linux/pci_ids.h
++++ b/include/linux/pci_ids.h
+@@ -1820,6 +1820,9 @@
+ #define PCI_VENDOR_ID_CB              0x1307  /* Measurement Computing */
++#define PCI_VENDOR_ID_ADMTEK          0x1317
++#define PCI_DEVICE_ID_ADMTEK_ADM5120  0x5120
++
+ #define PCI_VENDOR_ID_SIIG            0x131f
+ #define PCI_SUBVENDOR_ID_SIIG         0x131f
+ #define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000